O seu servidor está a correr o PHP na versão 4.4.9 mas o WordPress 3.7.3 necessita de, pelo menos, a versão 5.2.4.